skip to Main Content

Con il filtro contenuti abilitato e la scansione antivirus è capitato che al riavvio del NethService non vada più la navigazione. Solo al riavvio, non con un salva e riavvia da interfaccia, nel messages troviamo:

Aug 31 17:39:00 mail dansguardian[4612]: Error connecting to proxy
Aug 31 17:39:00 mail dansguardian[4612]: Error connecting to proxy

Il problema è che havp non è partito. Perchè? Ecco il log di clamd

2010-08-31 16:40:03.705745500 Self checking every 1800 seconds.
2010-08-31 16:40:03.705750500 Listening daemon: PID: 2983
2010-08-31 16:40:03.705755500 MaxQueue set to: 100

Ed il log di havp che dà errore

1/08/2010 16:40:02 --- Initializing Clamd Socket Scanner
31/08/2010 16:40:03 Clamd: Could not connect to scanner! Scanner down?
31/08/2010 16:40:03 ERROR: Clamd Socket Scanner failed EICAR virus test! (Could not connect to scanner

Havp non trova clamd pronto e quindi non parte, e non essendo supervisionato non parte più fino al prossimo salva/riavvia da interfaccia.
Il problema non capita sempre e non è facilmente ripetibile, in questo caso clamav perdeva tempo nel leggere i propri db perchè non corretti:

2010-08-31 17:10:27.654878500 Reading databases from /var/clamav
2010-08-31 17:10:28.081758500 LibClamAV Warning: Detected duplicate databases /var/clamav/main.cvd and /var/clamav/main.cld, please manually remove one of them
2010-08-31 17:10:31.405943500 Database correctly reloaded (821956 signatures)

Abbiamo risolto il problema pulendo /var/clamav/ e rilanciando freshclam

 

Alessio Fattorini - Community Marketing Manager

Particolarmente attratto da tutto quello che aiuta ed incentiva le persone a lavorare e collaborare insieme.
In Nethesis creo community, racconto storie e lavoro con l'Open Source.
Community Strategist, Copywriter, Speaker internazionale e Linux Sysadmin

Back To Top